Requirements

  • Compatible with iPhone, iPod touch, and iPad. Universal application.
  • Requires iOS 8.0 or later.
  • All content is self-contained. No Internet connection is required.